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General information

Wireless diagnostic tool and duty to maintain

The use of wireless diagnostic tools does not replace the prescribed 
maintenance intervals that apply to smoke detector system 
components (see Dual& nbsp;Q smoke alarm device operating 
manual, Dual/VdS, wireless modules and the system description). 
The maintenance intervals must be carried out independently of the 
use of the wireless diagnostic tools.

Interruption of alarm forwarding

The wireless diagnostic tool enables the diagnostic functions of the 
smoke detectors. Through this activation, in rare cases, the alarm 
forwarding between your wireless networked smoke alarm device 
could be interrupted for a maximum of four minutes. After the 
four minutes are up, any active alarms will be received and routed 
through the wireless network.
The function of each smoke detector is ensured at all times.

Influence of wireless diagnostic tools on the battery life

Note the following:
• Diagnostic tool + SAD (smoke alarm device) Dual Q: the life of 

the battery installed in the smoke detector (not replaceable) and 
the battery used in the wireless module (replaceable) are 
adversely affected.

• Diagnostic tool + SAD Dual/VdS: only the life of the battery 
installed in the smoke detector (replaceable) is adversely affected.

• Particularly the use of the function "Cyclic recording" with short 
recording cycles will shorten the battery life significantly.
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Product features

The wireless diagnostic tool is used to check the smoke alarm device 
Dual Q with wireless module or Dual/VdS with wireless module.
The wireless diagnostic tool consists of the wireless diagnosis USB 
box and the wireless diagnosis software.
• Installation control and status overview of smoke detectors.
• Connection of the wireless diagnosis USB box to the USB interface 

of a PC.
• Reading of the contamination level, serial number, battery voltage 

of the smoke detector, temperature and the last 20 events in the 
event memory via wireless.

• LED control of the wireless diagnosis USB box indicates the 
applied voltage supply.

Scope of supply
• Operating instructions
• Quick Start Guide
• Mini-CD (includes wireless diagnostic software and driver software 

for wireless diagnosis USB box).

Install the driver software

1. Install the drivers for the wireless diagnosis USB box from the 
mini-CD. Follow the instructions with the driver and install the 
software.

2. Connect the wireless diagnosis USB box via the included USB 
cable to a USB port on the PC.

3. The PC searches and automatically installs the driver for the 
wireless diagnostic tool.

Software settings

COM port
After installing the USB driver and connecting the wireless diagnosis 
USB box to the PC, a "virtual" COM port is established.
This COM port is used only for communication between the wireless 
diagnostic software and wireless diagnosis USB box.
Once the diagnosis software has located and connected to the 
wireless diagnosis USB box via the corresponding port, the 
information "Connected to [COMx]" appears in the status line of the 
diagnostic software.

Language
In [Menu] -> [Settings] -> [Language] the user can choose between 
German and English for the menu language.

System pre-conditions

• PC with Windows XP, Windows Vista or Windows 7 and installed 
Microsoft NET Framework 3.5 (available for free from Microsoft).

• Mini CD compatible CD/DVD drive.
• USB port with 500mA to power the wireless diagnosis USB box.

Make sure to comply with the installation order

The sequence described above must be observed to avoid malfunc-
tioning.

Check diagnosis software for updates and download them

Gira makes updates available in its download area (www.gira.de/ser-
vice/download/software) for the diagnostic software. After installa-
tion, check how current the diagnostic software is.

Wireless diagnosis USB box is not found

If the wireless diagnosis USB box can not be found automatically, the 
search can be repeated in [Settings] -> [Connect].
One reason for not being able to locate the wireless diagnosis USB 
box could be that the wireless diagnosis software was started before 
the wireless diagnosis USB box was connected, or before the drivers 
were installed.



Setting up the project

In [File] -> [New Project] a new project is created.
In [Edit] -> [Project Setup] the editing mask for setup can be called 
up at a later time.

Add a smoke alarm device to your project
Searching for smoke alarm devices is done in two steps.
1. The group address of a smoke alarm device is read.
2. Search for all the smoke alarm devices associated with the group.
A newly-detected smoke alarm device will be automatically added to 
the project and the search for further smoke alarm devices will 
continue.

Locate a smoke alarm device

Smoke alarm device Dual Q
1. Loosen the smoke alarm device from the mounting plate and start 

the programming mode on the wireless module (Hold down the 
Prog button for 4 sec.).

2. Lock the smoke alarm device onto the mounting plate.
3. Press the function key.

4. Once the smoke alarm device has sent its group ID, loosen the 
smoke alarm from the mounting plate again and exit the 
programming mode on the wireless module.

5. Lock the smoke alarm device onto the mounting plate.

Smoke alarm device Dual/VdS
1. Press the [Locate Smoke Alarm Device] button and activate the 

transmission of the group information on any smoke alarm: 
activate the programming mode on the smoke alarm Dual/VdS 
(press the function key on the smoke alarm).

2. Once the smoke alarm device has transmitted its group ID, exit 
the programming mode.

3. After confirming the group address the group is searched for 
associated smoke alarm devices.

The search can be repeated any time. Only smoke alarm devices that 
are not yet known are added to the project.

Setting up the project

The following applies when setting up a project:
• All smoke alarm devices in a building or a housing unit can be 

summarised in a project.
• Any number of smoke alarm devices can be added to a project.
• The smoke alarm device assigned to a project does not necessarily 

have to belong to a group.
• Ensure that all smoke alarm devices associated with the project 

are in wireless range of the wireless diagnosis USB box.
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Naming the smoke alarm devices
Smoke alarm devices are given names for convenience purposes only, 
as it facilitates assignment within the building. The naming 
convention (e.g. Kitchen) will be displayed along with the smoke 
alarm ID and the group address and reproduced in the measurement 
data.
The designation is limited to 20 characters.

Switching the ringing tone on and off
Activate a signal tone on the smoke alarm device via the wireless 
diagnosis software. After approx. 30 sec., the smoke alarm device 
gives visual and audible feedback. This makes it possible to locate any 
smoke alarm device, even in complex installations.
The [Signal On] button activates the signal tone. To switch off, follow 
the same procedure.
During the ringing of the tone, the tone can also be deactivated by 
pressing the function button on the smoke alarm device itself.

Search all smoke alarm devices in a group
Newly-assembled and an existing group of associated smoke alarm 
devices can be located in the relevant group using the [Find] button. 
Any new smoke alarms that are detected are automatically added to 
the list.

Clear smoke alarm devices from the list
Smoke alarms that no longer exist or are no longer found are not 
automatically deleted from the list.
Use the [Delete] button to remove a smoke alarm device from the list.
In [Edit] ->[Delete Smoke Alarm List] all smoke alarm devices can be 
permanently removed from the list.

Manage project

You can manage various projects with subordinate groups and 
individual smoke alarm devices.
All managed project data can be used at any time for a quick and 
reproducible diagnosis. For smoke alarm groups to which no changes 
were made, it is not necessary to reprogram the smoke alarm devices.
When creating a project, a project folder with the project name for the 
measurement data is created. In addition, a project file (*.rwm) with 
the relevant project data will be stored on the same level as the file.

New project
In [File] -> [New Project] a new project is created. Existing data 
(project data and measured values) are automatically stored and the 
list of smoke alarm devices and the measurement table are emptied. 
There is no data yet to be stored in the file system at this point. This 
step takes place only when the project is saved

Save project
Under [File]->[Save Project] the current project is saved. If no name 
has been assigned for the project, a prompt appears. The same 
applies to the measurement data. If a name has yet to be assigned, 
the user will be prompted to enter a name before storing the 
measurement data.

Open project
Under [File]-> [Open Project] all project data already saved are 
loaded. Existing data (project data and measured values) are 
automatically stored and the list of smoke alarm devices and the 
measurement table are emptied.

Save project as
Under [File]-> [Save Project As] an opened project can be saved 
under a new name.
Example old file name: RWM_Musterhaus_010120016
New file name: RWM_Musterhaus_01062016



Measured values

Once the data is read from a smoke alarm device, they are appended 
to the measurement table. Measurement tables are stored in XML 
format in the file system. Alternatively, the data contained in a 
measurement table can also be exported in CSV format.

Open measured values
Under [File]->[Open Measured Values] the stored values are loaded.
The wireless diagnosis software does not perform any checks on 
whether the measured values match the project data.

Save measures values as
Under [File]->[Save Measured Values As] the measured values are 
stored.

CSV export
The measured values are stored as a CSV file through the CSV export.
The CVS export enables the processing of the measured values with 
CSV-format compatible applications (for example, Microsoft Excel).

Print measurements
Under [File]->[Print] the measured values shown are printed. Here, a 
print preview is displayed where, for example, the page settings can 
be adjusted and the printer can be selected. A data export in other 
formats (e.g. PDF) is possible if the appropriate drivers are installed 
on the computer.
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Diagnosis

The wireless diagnosis tool can read various forms of status 
information for a smoke alarm device.

Status information such as temperature, pollution level and battery 
voltage are included with colours (traffic light function) in addition to 
the measured value.

The event log is displayed separately for each smoke alarm device and 
lists the last 20 events, such as alarms and error information (for 
example, a power failure or low battery).

*SAD = Smoke alarm device

Colour Recommendation

Green No maintenance required

Yellow Maintenance recommended (still functioning)

Red Maintenance required (function limited)

Column Description Information

Time stamp Time and date when 
the diagnostic data was 
received from the SAD

Surname Designation of the 
SADs in the project

Common name, 
e.g. "Kitchen"

Serial number Serial number of the 
SAD

Required for service requests

Temperature Current temperature 
internally measured by 
the SAD. This is contin-
uously updated by the 
SAD

For temperatures above 50 
°C SAD can trigger a heat 
alarm. If the temperature 
measured by the SAD distin-
guishes itself significantly 
from the room temperature, 
the installation site should be 
checked.

Pollution level This percentage value 
indicates how diry the 
space chamber is (e.g. 
with dust).

< 80% = green
≥ 80% = yellow
= 100% = red

Starting with a contamina-
tion level of 100%, the SAD 
signals an error. The internal 
control can no longer com-
pensate for certain contami-
nation.
If, after a short time, a high 
contamination level is meas-
ured on any of the SADs 
installed, the installation site 
must be the checked.

Battery-
Voltage

Display of the current 
residual voltage found 
in the battery of the 
smoke alarm device, in 
Volt [V]. New batteries 
have a voltage of about 
DC 9 V.

> 7 V = green
≤ 7 V = yellow
≤ 6,8 V = red

According to the provisions, 
the SAD must monitor the 
battery voltage. The warning 
"Low Battery" allows for 
timely replacement of the 
battery (dual/VdS SAD only). 
Through the wireless diagno-
sis, the battery of the SADs 
receives an extra load and 
the battery service life is 
shortened (Low battery 
already at about 6.8V).

Group Internal Wireless ID of 
the SAD group.

Alarm device Internal Wireless ID of 
the individual SADs.



Read the smoke alarm device
In the operating mode "Read device" a wireless diagnosis software 
can perform a targeted reading of an individual smoke alarm device. 
The smoke alarm devices can be selected from the list of smoke alarm 
devices. The selected smoke alarm device is listed next to the Start 
button. By clicking on [Start] the wireless diagnosis software starts to 
read the corresponding smoke alarm device. The reading of a smoke 
alarm is finished after about 1 minute. The data obtained will be 
added to the measurement table. The process can be interrupted at 
any time using the [Stop] button.

Diagnosis
In the "Diagnostics" operating mode, all selected smoke alarm 
devices in the list are read out sequentially. A selected smoke alarm 
device has a checked box before the name of the smoke alarm. The 
data obtained will be added to the measurement table as soon as the 
smoke alarm device has been read. The diagnosis is complete when 
all of the smoke alarm devices have been read. The process can be 
interrupted at any time using the [Stop] button.
During diagnosis, a query time of about 1 minute per alarm device 
should be expected.

Cyclic recording
In the operating mode "Cyclic recording" a diagnosis is carried out at 
the selected interval. The wireless diagnosis software checks whether 
all of the smoke alarm devices can be read out at the predetermined 
interval. If necessary, select a longer interval.
Depending on the smoke alarm device, approx. 1 minute is needed for 
the data to become available and read into the software. The 
maximum duration of the diagnostic data recording should not 
exceed 14 days so that the battery of the smoke alarm device does not 
become overburdened.

Show event memory (only dual/VdS smoke alarm devices)
A smoke alarm device should be capable of internally storing the last 
20 events (for example, smoke alarm, test alarm or low battery 
condition).
• During each reading of a dual/VdS smoke alarm device, the event 

memory of the smoke alarm is also read.
• After selecting a dual/VdS smoke alarm device, the event memory 

of the corresponding smoke alarm device is displayed. The data 
can be updated by reading a dual/VdS smoke alarm device.

• All data are presented in chronological sequence, with the most 
recent event at the top.

• Within the smoke alarm, the event log information is updated in 
the active events shown in the table.

• In addition, the most recent events are updated in the cycle of 20 
days or 20 days after the last event if there is no other event.

• The passive events described are logged with each event memory 
update, but do not trigger an update of the event log.
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*SAD = Smoke alarm device

Signal
In the "Signal" operating mode, the signaling of a smoke alarm is 
switched on or off in order to find the smoke alarm.

Uninstall the USB driver software

1. In [Windows] -> [System Control] -> [Programme] -> [Uninstall 
Programme] pull up the list of installed programs and drivers.

2. Select the diagnostic software and in [right mouse-click] -> 
[Uninstall], delete it.

3. Select the driver software and in [right mouse-click] -> 
[Uninstall], delete it.

Technical data

Event memory recording Meaning

Active smoke alarm device events

Smoke alarm This SAD triggered an alarm based on 
the measured atmospheric opacity 
(smoke). This alarm was transmitted to 
the other (wireless) networked SADs.

Temperature alarm This RWM triggered an alarm based on 
the measured temperature or tempera-
ture change. This alarm was transmitted 
to the other (wireless) networked SADs.

Wireless alarm This RWM reported an alarm that was 
transferred via wireless from another 
SAD.

Alarm wire This RWM reported an alarm that was 
transferred via wire from another SAD.

Weak battery This RWM issued the warning 
"Low Battery".

SC error Smoke chamber code

TS error Temperature sensor code

Passive smoke alarm device events

230 V failure Indicates whether the 230 V SAD was 
supplied at the time of the recording. If 
the 230V SAD was not supplied, this 
entry is always set.

Wireless test alarm This RWM reported a test alarm that was 
transferred via wireless from another 
SAD.

Wire test alarm This RWM reported a test alarm that was 
transferred via wire from another SAD.

Status Smoke alarm status code

Power supply: via USB cable

USB port

Type: 1.1

Amperage: 500 mA

Wireless bus

Transmission frequency: 433.42 MHz, ASK

Transmission range: 100 m (free field)

Ambient temperature: -5 °C to +50 °C

Dimensions (H x B x T):  110 x 38 x 100 mm



Products and solutions

Warranty

The warranty is provided in accordance with statutory requirements 
via the retailer.
Please submit or send faulty devices postage paid and with an error 
description to your sales representative (retailer/installation 
company).
The salesperson will forward the devices to the Gira Service Center.

Problem Solution

The diagnostic software or 
its installation will not start

The diagnostic software requires the 
Microsoft .Net Framework 3.5.

The software requires Windows XP, 
Windows Vista or Windows 7.

The wireless diagnosis soft-
ware can not connect to the 
wireless diagnosis USB box

The wireless diagnosis USB box is not 
adequately supplied with power from 
the USB port.
=> Use another USB port 
(USB Power) or
=> Use a USB hub with an external 
power supply.

The necessary USB driver is not 
installed or is not properly installed.
=> Reinstall the USB driver from the 
included CD or from the download 
section of Gira.

The USB cable is defective or not 
properly connected.
=> Check the USB cable connection.
=> Use a commercially available A/B 
USB cable as a replacement. Recom-
mendation: only use shielded cables 
< 3m.

=> Restart the PC to complete the 
driver installation

=> Restart the diagnostic software or
=> Choose "Connect" in the menu to 
begin a new search for the wireless 
diagnosis USB box

One or more SADs were not 
found during diagnosis or no 
diagnosis data were received

The transmission was disturbed by an 
interfering transmitter.
=> Repeat transmission, search for 
and disable the interfering transmitter

The SADs are out of wireless range of 
the wireless diagnosis USB box. => 
Reduce distance to the SAD.

SAD is not ready for operation.
Programming mode activated? => 
activate.
Sufficient power supplied over bat-
tery? => Change the battery.

The desired time can not be 
set during cyclic diagnosis

During diagnosis, approximately one 
minute is needed per alarm device to 
query the diagnostic data. Shorter 
query times as the total count SAD x 
1 min are therefore not possible.

The software stops respond-
ing after the USB connec-
tion has been disabled

The USB connection is disabled dur-
ing communication between the diag-
nostic software and the wireless 
diagnosis USB box.
=> End and restart the diagnostic 
software. Previously-recorded data 
are kept and can be restored by 
restarting the diagnostic software.
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